CentOS7.x 에서 php7.x 에서 php5.6.x 버전으로 다운그레이드하는 방법

CentOS 7.x 버전에서 yum 방식으로 PHP 7.x에서 PHP 5.6.x 버전으로 업데이트하는 방법을 살펴 봅니다.

다운그레이드 순서는 다음과 같습니다. (root 권한으로 수행해야 합니다)

 

먼저, 기 설치된 PHP 7.x 을 삭제합니다.

 

# yum remove php php-bcmath php-cli php-common php-devel php-gd php-mbstring php-mysql php-odbc php-pdo php-process php-xml php-xmlrpc

 

PHP 5.6.x 를 재설치합니다.

 

# rpm -Uvh https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm

# rpm -Uvh http://rpms.famillecollet.com/enterprise/remi-release-7.rpm

# yum list –enablerepo=remi –enablerepo=remi-php56 | grep php

 

패키지 설치

# yum install –enablerepo=remi –enablerepo=remi-php56 php php-bcmath php-cli php-common php-devel php-gd php-mbstring php-mysql php-odbc php-pdo php-process php-xml php-xmlrpc (필요한 패키지 나열)

 

아파치 재시작

# systemctl restart httpd

[root@calypso ~]# php -v
PHP Warning: PHP Startup: apc: Unable to initialize module
Module compiled with module API=20100525
PHP compiled with module API=20131226
These options need to match
in Unknown on line 0
PHP 5.6.40 (cli) (built: May 28 2019 10:47:03)
Copyright (c) 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies

 

 

 

 

No comments
Write CommentLIST
WRITE COMMENT

This site uses Akismet to reduce spam. Learn how your comment data is processed.

위로이동