CentOS 7에서 php 7.2 버전으로 업데이트 방법 (yum 방식)

이 글은 이전 CentOS7.0 에서 yum 방식으로 php5.6.x 버전 설치하기 이후 PHP 7.2 버전으로 업데이트 하는 방법을 설명하고 있습니다. 업데이트 순서는 다음과 같습니다.

 

우선 remi repository를 yum 에 추가 합니다.

 

$ 더블유겟 https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm
$ rpm -Uvh epel-release-latest-7.noarch.rpm
$ 더블유겟 http://rpms.remirepo.net/enterprise/remi-release-7.rpm
$ rpm -Uvh remi-release-7.rpm

$ yum-config-manager –enable remi-php72

 

만약 설치되지 않고 dependency로 인해 정상 설치 되지 않은 경우 설치된 php 및 패키지를 먼저 삭제하고 다시 설치를 합니다.

 

PHP 패키지 삭제

 

# yum remove php php-bcmath php-cli php-common php-devel php-gd php-mbstring php-mysql php-odbc php-pdo php-process php-xml php-xmlrpc

 

PHP 패키지 설치

 

# yum install –enablerepo=remi –enablerepo=remi-php56 php php-bcmath php-cli php-common php-devel php-gd php-mbstring php-mysql php-odbc php-pdo php-process php-xml php-xmlrpc (필요한 패키지 나열)

 

정상 설치되지 않고 하단과 같은 에러가 뜹니다.

 

Error: Package: php-cli-7.2.12-1.el7.remi.x86_64 (remi-php72)
Requires: libargon2.so.0()(64bit)
Error: Package: php-7.2.12-1.el7.remi.x86_64 (remi-php72)
Requires: libargon2.so.0()(64bit)

 

 

libargon2 패키지 설치

 

# 더블유겟 https://dl.fedoraproject.org/pub/epel/7/x86_64/Packages/l/libargon2-20161029-3.el7.x86_64.rpm

# rpm -Uvh libargon2-20161029-3.el7.x86_64.rpm

# 더블유겟 https://dl.fedoraproject.org/pub/epel/7/x86_64/Packages/l/libargon2-devel-20161029-3.el7.x86_64.rpm

# rpm -Uvh libargon2-devel-20161029-3.el7.x86_64.rpm

 

PHP 패키지 재설치

 

# yum install –enablerepo=remi –enablerepo=remi-php56 php php-bcmath php-cli php-common php-devel php-gd php-mbstring php-mysql php-odbc php-pdo php-process php-xml php-xmlrpc (필요한 패키지 나열)

 

정상 설치된 경우 다음과 같은 메시지 볼 수 있습니다.

 

 

아파치 재시작

 

# systemctl restart httpd

 

 

PHP 버전 확인

 

 

 

 

No comments
Write CommentLIST
WRITE COMMENT

This site uses Akismet to reduce spam. Learn how your comment data is processed.

위로이동