워드프레스 글 본문 이미지가 사용자 화면에서 출력되지 않는 경우가 있습니다

한 클라이언트로부터 다음과 같은 요청이 왔습니다.

 

워드프레스에서 새 글을 작성하고, 이미지를 추가 하였습니다. 글 작성 완료 후 공개하기를 했는데, 관리자 화면에서는 이미지가 잘 보이는데 사용자 화면에서는 이미지가 보이지 않습니다. 도대체 무슨 문제인가요?

 

그래서 먼저 다음과 같이 글 작성 완료된 화면을 살펴 보았습니다.

 

jetpack-photon-error

 

 

 

다른 글과 차이점을 찾지 못해 이 글을 다음과 같이 사용자 화면에서 보았습니다.

 

jetpack-photon-error1

 

 

위 그림처럼 정말 이미지가 보이지 않더군요. 처음에는 단순히 이미지 경로가 잘못 되었나보다 생각하고 워드프레스 관리자 화면에서 이미지 경로를 확인해 보았는데, 이 문제는 아니었습니다. 혹시 파일명이나 파일 용량 문제인가 확인해 보았지만, 역시 이 문제도 아니었습니다. 그래서 실제 사용자 화면에서 이미지 경로가 어떻게 표시되는지 확인해 보았습니다.

 

 

jetpack-photon-error2

 

 

 

그랬더니 위 그림의 이미지 src처럼 도메인 앞(hif.co.kr)에 i2.wp.com 이라는 정체를 알 수 없는 URL이 추가된 것을 확인할 수 있었습니다. 도대체 이 코드가 어떻게 들어간 것인지 도무지 알 수가 없었습니다. 혹시 해킹된 것인가? 하는 생각이 들어 플러그인 및 테마를 점검했지만, 다행히 해킹은 아니었습니다.

 

그래서 이번에는 워드프레스 내에서 i2.wp.com 패턴이 들어간 파일을 찾아 보았더니, 다음과 같이 무엇인가 걸리는 것이 있었습니다.

 

 

jetpack-photon-error3

 

 

 

위 그림처럼 jetpack과 photon 키워드를 얻은 다음, 실제 Jetpack 모듈이 설치된 곳을 확인해 보았더니 다음과 같이 Phonton 모듈이 활성화 되어 있었습니다.

 

 

jetpack-photon-error4

 

 

 

그래서 위 그림의 Photon 모듈을 비활성화한 다음, 앞서 설명한 이미지가 포함된 글을 사용자 화면에서 확인 했더니, 다음과 같이 정상 출력되는 것을 확인할 수 있었습니다.

 

 

jetpack-photon-error5

 

 

 

Comment 1
Write CommentLIST
  1. hyunseok park2019.3.7 AM 10:52

    감사합니다.
    오늘 아침 갑자기 홈페이지 내의 모든 이미지라 로드가 안되는 증상이 발생했고, 편집할 때는 이미지가 뜨는 현상이 발생했습니다.

    편집에서는 이미지가 연결되기에 링크가 깨진것은 아니기에 플러그인 (특히 SEO관련) 이 문제일 것이라고 예상은 했었는데 이렇게 답을 주시니 감사합니다. 문제는 젯펙이었습니다.

    2019년 지금은 저 포톤 메뉴가 아니라 “사이트 가속기” 중 “이미지 로드 시간이 빨라짐” 을 비활성화 하니 문제가 해결되었습니다.

    감사합니다.

WRITE COMMENT

This site uses Akismet to reduce spam. Learn how your comment data is processed.

위로이동